Librenms not detecting my system metrics

I have added 2 servers to my libreNMS out of the 2 servers, one server is running libreNMS, one is running FTP server, both are running on UBUNTU 20.04 LTS.
The libreNMS server metrics i am able to see
the ftp server metrics i am not able to see.

Need help in how to see the server metrics of the FTP server

Firewall on ftp server?

Can you snmpwalk it from the librenms server?

i have not enabled firewall on the ftp server right now, as its running on a private network.

i am new to Ubuntu, i have installed the snmp protocol but i am not clear on how to snmpwalk it

I have the same problem.
I added a localhost node.

From the console, polling works:
librenms:/opt/librenms$ snmpwalk -v2c -c librenmsdocker localhost
SNMPv2-MIB::sysDescr.0 = STRING: Linux librenms 5.4.0-121-generic #137-Ubuntu SMP Wed Jun 15 13:33:07 UTC 2022 x86_64
SNMPv2-MIB::sysObjectID.0 = OID: NET-SNMP-MIB::netSnmpAgentOIDs.10
DISMAN-EVENT-MIB::sysUpTimeInstance = Timeticks: (8755375) 1 day, 0:19:13.75
SNMPv2-MIB::sysContact.0 = STRING: Your Name [email protected]
SNMPv2-MIB::sysName.0 = STRING: librenms
SNMPv2-MIB::sysLocation.0 = STRING: Rack, Room, Building, City, Country [Lat, Lon]
SNMPv2-MIB::sysORLastChange.0 = Timeticks: (0) 0:00:00.00
SNMPv2-MIB::sysORID.1 = OID: SNMP-FRAMEWORK-MIB::snmpFrameworkMIBCompliance
SNMPv2-MIB::sysORID.2 = OID: SNMP-MPD-MIB::snmpMPDCompliance
SNMPv2-MIB::sysORID.4 = OID: SNMPv2-MIB::snmpMIB
SNMPv2-MIB::sysORID.8 = OID: IP-MIB::ip

librenms:/opt/librenms$ ./validate.php

Component Version
LibreNMS 22.6.0
DB Schema 2022_05_30_084932_update-app-status-length (242)
PHP 7.4.29
Python 3.9.7
MySQL 10.5.16-MariaDB-1:10.5.16+maria~focal
RRDTool 1.7.2
SNMP 5.9.1

[OK] Installed from package; no Composer required
[OK] Database connection successful
[OK] Database Schema is current
[OK] SQL Server meets minimum requirements
[OK] lower_case_table_names is enabled
[OK] MySQL engine is optimal
[OK] Database schema correct
[OK] MySQl and PHP time match
[WARN] IPv6 is disabled on your server, you will not be able to add IPv6
[OK] rrd_dir is writable
[OK] rrdtool version ok
[WARN] Non-git install, updates are manual or from package

screenshot shows, device added 7 seconds ago. wait for discover and polling to complete

Please check snmp community string is correct in /etc/snmp/snmpd.conf

That’s because I deleted it and added it again.

Community string correct? Yes.

what is the error when you manually run the poller

./poller.php -h localhost

Strange, No issue in polling.
issue with only localhost, all other devices metrics are good ?

Yes, everything else works, except Weathermap, it does not save created maps.

check for any errors in poller_wrapper.log (assuming you are using cron based polling )

cat poller_wrapper.log | grep “device 98”

I’m not such an advanced Librenms user yet, I don’t understand where to look?
I also noticed that sometimes, something happens and the node starts polling for a short time.

from the screenshot, it is clear that host is not responding to poller.
to check the poller log,

login to librenms server through cli, after that apply below commands to check the logs

sudo su librenms
cd /opt/librenms/logs
cat poller_wrapper.log | grep “device 98”

post the output

Only this:
librenms:/data/logs$ cat poller_wrapper.log | grep “device 98”
2022-07-13 18:05:25,734 :: INFO :: worker Thread-5 finished device 98 in 2 seconds

manual poller is working, scheduled poll is working. still no device data.
sorry, not sure what else to check
lets see if others have any idea

I completely uninstalled the current installation and reinstalled everything. But the data still didn’t show up.

I manually ran the poller and the information was updated.
But after 5 minutes the node turned red. So the automatic poller is not working?

This is what I was able to see in the console:

I do not understand why in manual mode the node is polled, in automatic mode it is not available?

Try below setting in config.php. This is not a solution , but to see if its responding by increasing the time

$config[‘snmp’][‘timeout’] = 5;
$config[‘snmp’][‘retries’] = 10;
$config[‘snmp’][‘exec_timeout’] = 1200;

above timers are in seconds