Memory Pool

Tags: #<Tag:0x00007f9754c23808>

Hi Guys.

is there a way to specify or tell libre to only poll physical memory usage and not the cached memory because acording to Libre I’m using 98% of my RAM

image

I am using Ubuntu and I know it takes al the ram puts it in cache and gives as needed.

I would just not like to see it.

Thank you in advance!

Hi guys does anyone have any idee of what can be done here

If you run free -h and check Free Memory this should be correct. Your thinking of Available memory which is not reported in LibreNMS as i don’t think it’s available over snmp, you can test yourself against some of the oids http://www.net-snmp.org/docs/mibs/ucdavis.html

Check the discussions here:
#https://github.com/librenms/librenms/issues/5660
#https://github.com/librenms/librenms/issues/3179

Not sure of another way, you could possibly explore a nagios plugin to monitor available memory as a librenms service.

1 Like

do you know why this is?

No one has added support to show both on the main overview page.
For network devices, showing free memory is correct. Available memory only applies to Linux and Windows servers.

But as you can see on the graph you linked, it does have the data from at least Linux devices.

Pull requests (code changes) are welcome.

This is how newrelic pulls the memory in.

Query
SELECT average(memoryUsedBytes/memoryTotalBytes*100) AS 'Memory used %' from SystemSample WHERE entityId = '2374099761232768672' TIMESERIES

Any one know of a fix as of yet?

No, nobody has contributed changes or code for that.

Do you have this same error on your Libre?

No because I don’t personally monitor on my Linux systems the physical memory. I monitor the swap space.

Hi,
I have the same issue. After reboot of LibreNMS server (Ubuntu 18.04), the cached memory increases up to use 90% and more. After some hours or days, the system slowdown and finally hangs. To avoid this, I’m currently rebooting server every 24 h.
Not yet found a solution for this issue. I cannot understand if the tuning must be done on LibreNMS or the Linux machine itself.
Same issues for anybody?

So I’ve done some testing on Ubuntu 18.04 and 16.04 both of my test machines did not give this memory error

Which is weird so I taught maybe it is the way the device is discovered and polled for the first time I deleted the host with the memory problem and re-added his and got the same error did this bout 4 time with no luck.

and after all this testing I was only left with sadness!!

RRDCached installed?

I am not 100% sure, but I think not installed.
Should be installed?

What do you mean?

If it is installed, could be a reason for why Cached memory keeps going up.

how will I be able to check?

Hi Gents,

Any one know about a fix for this?