Oxidized Git Versions - Missing

Tags: #<Tag:0x00007f3b89fd2868>

My issue is I do not see versions in Oxidized (or obviously LibreNMS).

I recently setup Oxidized and LibreNMS on Ubuntu 18.04. I enabled the LibreNMS integration with Oxidized per the Global Settings. I have also enabled groups in config.php (LibreNMS Config Pastebin):

When I go to view configs in LibreNMS they show up fine, BUT versions do not.

In researching this further I found that Oxidized Web UI is not showing versions either (Error: ArgumentError at /node/version ## wrong number of arguments (given 0, expected 1+)). Which I’ve seen before in that Oxidized doesn’t see any versions (My explanation).

So, I figured I do not have Oxidized setup (Oxidized Config Pastebin) correctly to show my versions. Following another thread in this community ( Oxidized integration problem - not pulling versions) I tried the git clone, and then git log with the following results (Git Clone/Log Pastebin). So I believe I actually am tracking config change versions and they just are not being picked up. All I am changing is the name of a port with a Time/Date stamp.

Any suggestions as to what I’ve missed or what to do next?

Thank you in advance!

SOLVED! I found this fix on github: #2049

image