Polling/discovering Ubiquiti Unifi devices

At home, I run another instance of Libre for my own network monitoring. For the most part, it works well, but for whatever reason, I’m unable to get HW health info out of my switches (US-8-150W). Interface stats, etc, work fine.

This thread…

…suggests that this was corrected in subsequent updates…and it’s been some time since that’s occurred, but for some reason, my switches are not getting these stats discovered.

I suppose you can assume a bog standard install in this regard, and I’ve tried to see if there were any differences between v2c and v3, but nada. There’s nothing obvious that I can see that would preclude this from working.

I’d tried to DM the OP in that thread, but unfortunately he didn’t reply.

Per usual, I’m open to suggestions.


I am getting temp from my Ubiquiti 16 port PoE’s… but they are Edgeswitch rather than Unifi. Post up your ./validate.php. I will post mine for quick comparison.

[email protected]:~$ ./validate.php

Component Version
LibreNMS 1.45-34-gd3f5dc682
DB Schema 270
PHP 7.2.10-0ubuntu0.18.04.1
MySQL 10.1.34-MariaDB-0ubuntu0.18.04.1
RRDTool 1.7.0


[OK] Composer Version: 1.7.3
[OK] Dependencies up-to-date.
[OK] Database connection successful
[OK] Database schema correct

My Unifi APs show up when I enable SNMP in the Unifi Controller

From the controller dashboard select Settings --> Servces --> SNMP

Enable SNMP, set your community string & click apply. Then add the devices by IP Address.

Component | Version
--------- | -------
LibreNMS  | 1.45-34-gd3f5dc6
DB Schema | 270
PHP       | 7.0.32-0ubuntu0.16.04.1
MySQL     | 10.0.36-MariaDB-0ubuntu0.16.04.1
RRDTool   | 1.5.5
SNMP      | NET-SNMP 5.7.3

[OK]    Composer Version: 1.7.3
[OK]    Dependencies up-to-date.
[OK]    Database connection successful
[OK]    Database schema correct

I appreciate that you have Edge devices as opposed to Unifi…I believe the other thread was also Unifi, and for the most part, they’re the same devices. Whether the CLI differences between have anything to do with it, I don’t know, and I wouldn’t think so as SNMP is SNMP in this regard.


The issue isn’t that I’m not getting anything, it’s that I’m not getting some data out of the switches. My estate is fully monitored other than these metrics. My APs, and USG are getting just about everything that I think it should (don’t think the USG, in particular the USG3 has temp stats and the like).

I don’t have any great answers but here is the poller snippet from my PoE edgeswitch that is picking up the temp - maybe edit the device and double check the sensors module is on and running a rediscover? Or turn it off, rediscover, then back on again and rediscover? (yea, that’s a lame Help Desk answer hahah!)

[RRD Disabled]SQL[SELECT * FROM sensors WHERE sensor_class = ? AND device_id = ? [“temperature”,83] 1.02ms]
SNMP[/usr/bin/snmpget -v2c -c COMMUNITY -OUQnte -M /opt/librenms/mibs:/opt/librenms/mibs/edgeswitch udp:HOSTNAME:161 . . . . . .]
..4.1.44..1.0 = 63
.4.1.44*..1.1 = 49
.4.1.44*..1.2 = 37
.4.1.44*..1.3 = 41
.4.1.44*..1.4 = 39
.4.1.44*.*.1.5 = 39

Checking (snmp) temperature Temperature 1.0…
Checking (snmp) temperature Temperature 1.1…
Checking (snmp) temperature Temperature 1.2…
Checking (snmp) temperature Temperature 1.3…
Checking (snmp) temperature Temperature 1.4…
Checking (snmp) temperature Temperature 1.5…
RRD[update N:63 --daemon unix:/var/run/rrdcached.sock]
[RRD Disabled]49
RRD[update N:49 --daemon unix:/var/run/rrdcached.sock]
[RRD Disabled]37
RRD[update N:37 --daemon unix:/var/run/rrdcached.sock]
[RRD Disabled]41
RRD[update N:41 --daemon unix:/var/run/rrdcached.sock]
[RRD Disabled]39
RRD[update N:39 --daemon unix:/var/run/rrdcached.sock]
[RRD Disabled]39
RRD[update N:39 --daemon unix:/var/run/rrdcached.sock]
[RRD Disabled]

Runtime for poller module ‘sensors’: 0.0525 seconds with 2696 bytes
SNMP: [3/0.04s] MySQL: [4/0.00s] RRD: [0/0.00s]

Unload poller module sensors

Running a new discovery, and picking out the MIB in question to what you have above, I had different results. I’ll save you all from pasting that in.

However, running the following:

[email protected]:/opt/librenms/mibs/ubnt# snmpwalk -v 2c -c <>
iso. = No Such Object available on this agent at this OID

Basically, it seems as though it’s not being picked up at all on this platform, which is a bit strange.

I’m going to say it’s a Ubiquiti issue, so I’ll take it up with them.

It’s also possible that because it’s a smaller unit, the OID in question being specific to Broadcom, this platform flat out has different HW…I don’t know specifically what this is running to that end.