Possible Glitch ! Can't Delete the Device

I have two devices somehow added as below

I tried to edit/overwrite/maintenance mode. But there is no way i can delete them. After deleting confirmation it says ‘no such host’ . But the devices remains in the system. How to delete these ?

same issue here, @jasim_alam did you get the issue resolved ?

Only way to delete these is via SQL DELETE FROM `devices` WHERE `device_id`=999999999; (where 999999999 is the device_id in the url)

I still haven’t figure out what is adding these…

can you walk me step by step ?

You have to enter mysql cli:

mysql -u librenms -p librenms
That will ask you for a password, you can look it at .env or config.php

Then run the query murrant said with the correct device_id.

THANKS ! worked :slight_smile:

@murrant I think this happened to me in the past and was part of a failed test.

1 Like

to find device_id in database, just do like this :
MariaDB [librenms]> SELECT device_id, hostname, sysName, ip FROM devices;