Time change and Email alert sending issue

Issue 1:
I am trying to implement the email push feature. I setup the email under the Alert Transport and tried sending a test email and it is OK with the test email. I am able to receive the email.
Then, I created Alert Rules and added the IP address and the email list but do not received any email alert when the device goes down or up. Below is one of the rule assigned picture for the reference:

Issue 2:
I have installed the pre-build version of LibreNMS in Virtual Box. Everything OK but the timezone seems to be different. Today I changed the timezone to Aisa/Tokyo but still the browser not showing the proper timezone. Below is the picture for your reference:

Can anyone please help me to solve these two issues that i mentioned above? Thankyou

Hi @laf ,
Is there any possible solution for the above issue?
I tried to follow the previous solution that you have posted.

In the above link do we need to delete any of the *.lock file . I can see the composer.lock file here in my case.

Hello @Chadwick ,

Do you have any idea about the above issue?

Thankyou in advance

For #2:
You must configure your PHP using “Asia/Tokyo” as timezone

If you have UBUNTU you edit

vi /etc/php/8.1/fpm/php.ini
vi /etc/php/8.1/cli/php.ini

If you have Centos you edit

vi /etc/php.ini

And then for the system

timedatectl set-timezone Asia/Tokyo

For #1:

There are ALOT of variables that go into making this work.

  1. Just because the SMPT test reports OK, doesnt mean that it is.
  2. Have you somehow actually received an email, or are you assuming that you should, based on test?
  3. Are you using an email account that has the proper security settings

Here is a link to a video covering setting this up and what to look for:

Has any of this information helped your situation?

HI @Chadwick ,
I followed the same video. The test email is OK however the auto email is still not working

At present, It could be a great help if somebody could tell me how this email issue could be solved.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.