Trying to add new OS: env: ‘mib2c’: No such file or directory


I am trying to add a new OS (GitHub - alexk99/the_router: TheRouter is a software packet router based on DPDK an NPF libraries.) to my librenms installation.

When I tried runnning ./scripts/new-os.php I got the following error:

xxx@librenms:~$ sudo -u librenms /opt/librenms/scripts/new-os.php -h 112 -o br -t server -v bisonrouter

sysDescr: Linux bison-router 5.4.0-155-generic #172-Ubuntu SMP Fri Jul 7 16:10:02 UTC 2023 x86_64
sysObjectID: .

We already detect this device as OS linux type, do you want to continue to add sensors? (Y/n) Y
ctrl+c to exit now otherwise please enter the MIB name including path (url is also fine) for us to check for sensors: /opt/librenms/mibs/BISON-ROUTER-MIB
Do you want to add natTranslationStateCountersTable? (y/N) y
env: ‘mib2c’: No such file or directory

In Yaml.php line 73:

  Symfony\Component\Yaml\Yaml::parse(): Argument #1 ($input) must be of type string, nul
  l given, called in /opt/librenms/scripts/new-os.php on line 117

This is the output of validate.php:

xxx@librenms:/opt/librenms$ sudo -u librenms /opt/librenms/validate.php
Component | Version
--------- | -------
LibreNMS  | 23.11.0-17-gbe1eefc09 (2023-12-03T22:05:51+02:00)
DB Schema | 2023_11_21_172239_increase_vminfo.vmwvmguestos_column_length (274)
PHP       | 8.1.2-1ubuntu2.14
Python    | 3.10.12
Database  | MariaDB 10.6.12-MariaDB-0ubuntu0.22.04.1
RRDTool   | 1.7.2
SNMP      | 5.9.1

[OK]    Composer Version: 2.6.5
[OK]    Dependencies up-to-date.
[OK]    Database connection successful
[OK]    Database Schema is current
[OK]    SQL Server meets minimum requirements
[OK]    lower_case_table_names is enabled
[OK]    MySQL engine is optimal
[OK]    Database and column collations are correct
[OK]    Database schema correct
[OK]    MySQl and PHP time match
[OK]    Active pollers found
[OK]    Dispatcher Service not detected
[OK]    Locks are functional
[OK]    Python poller wrapper is polling
[OK]    Redis is unavailable
[OK]    rrd_dir is writable
[OK]    rrdtool version ok
[WARN]  Your local git contains modified files, this could prevent automatic updates.
        You can fix this with ./scripts/github-remove
        Modified Files:

I hope you could give me some insight into fixing this issue, I have found an earlier blog post with the same error but ultimately a workaround was found: Adding new os for Cisco WAP371

Thanks in advance

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.