When traffic on a LAG reaches above 100G the graph is zeroed out

Tags: #<Tag:0x00007f849f356648> #<Tag:0x00007f849f356580>

When the traffic on a 200G LAG reaches above 100G the graph is zeroed out. Is this a 32bit counter problem or something like that?

Using Chrome: 72.0.3626.96 (Official version) (64 bitar)

LibreNMS info:
|Version|1.48.1-64-g9dba9f626 - Mon Feb 18 2019 03:07:13 GMT+0100|
|DB Schema|2019_01_16_195644_add_vrf_id_and_bgpLocalAs (131)|
|Web Server|Apache/2.4.29 (Ubuntu)|
|PHP|7.2.15-0ubuntu0.18.04.1|
|MySQL|10.3.12-MariaDB-1:10.3.12+maria~bionic|
|RRDtool|1.7.0|

This should help https://docs.librenms.org/Extensions/RRDTune/

Thanks for the answer, but we don’t use that value under rrd tool settings. I checked both global, under device and under the ports.

LibreNMS reports the LAG as 200G. So it seems to get the correct values from SNMP.

LibreNMS settings:

According to the doc, the default RRD max is 100G.

Your ifSpeed is already 200G, then all you need to do is run the tune_port.php script for that device which alters the RRD file to max of 200G (ifSpeed) and you should start graphing.

Thanks, will try that!

Hmm, maybe the default needs to be increased…

2 Likes

Just to followup, tune_port.php all worked. Now all is well with the graphs.

nice one :slight_smile:

I have the saem issue, i have aply de fix, but this is not working for trunk, only for single ports.
is there another fix for trunk that reach more than 100G ??

1 Like

You need to run tune port manually on the trunk rrd if you can’t get the script to do it for you.