Widget list empty in docker install 1.66

This is on fresh ubuntu server 20.04 install, latest docker-ce from stable docker repository. Librenms installed via docker-compose with no errors reported with the .env files and docker-compose.yml from the examples @ https://github.com/librenms/docker.

Logs do not indicate any errors, adding devices, poller and pretty much everything I tried works, but when I try to add new widget to dashboard the list that pops up is just empty 3 pixel list of nothing. I can delete the default widget, the webpage reports Widget 0 deleted in green and that’s it.

As per this thread I tried in different browsers, but the list was empty in chrome (vivaldi, edge), firefox and IE.



Component Version
LibreNMS 1.66
DB Schema 2020_06_23_00522_alter_availability_perc_column (171)
PHP 7.3.20
Python 3.8.5
MySQL 10.4.14-MariaDB-1:10.4.14+maria~focal
RRDTool 1.7.2


[OK] Installed from the official Docker image; no Composer required
[OK] Database connection successful
[OK] Database schema correct
[WARN] IPv6 is disabled on your server, you will not be able to add IPv6 devices.
[WARN] Updates are managed through the official Docker image

Any help appreciated, librenms is pretty much one of the last things I need to move to docker.

Hi there,
I too am experiencing this same issue. Brand new docker instances of LibreNMS and the widgets drop down is empty.

No obvious errors in the logs and all other features appear to be working correctly.

@CrazyMax does the docker image run migration seeds properly?

Good news, I recreated the stack as I noticed there were updates on the github page 2 days ago and the widget list is now populated and adding/removing widgets works!