Change to PHP minimum version >= 7.1


#1

We’re nearly 1 year on from the last minimum PHP version bump we did. At the end of last year, PHP themselves dropped support for PHP 5.6 and 7.0 and we’ve decided that we should follow. We should be doing what we can to ensure user installs are secure and this is one step we can take to help with that.

PHP 7.1 was released just over 2 years ago so is mature and stable enough. Some of the big distros don’t package this version by default so you may have to use a 3rd party repo to remain up to date. Our current install docs for CentOS 7 and Ubuntu 18.04 contain instructions on using a newer version of PHP.

On the 1st of Feb 2019, we will merge in support for validating the PHP version users are running, if this is below 7.1.3 then we will automatically move your install to a new branch php56. At this stage your install will no longer have any further updates applied to it until you upgrade PHP to 7.1.3 or later (7.2 is recommended).

Switching to 7.1.3 or above will allow LibreNMS to support PHP 7.3 and also give us the ability to upgrade some of the modules we use along with Laravel itself so we can continue our migration to using Laravel in full.

To clarify, at no stage during this will LibreNMS cease to work for you regardless of the PHP version you run. It just means you main not receive any further updates unless you are running a more recent version of PHP.


#2

Hi All!
Does anyone has a working setup of Weathermap plugin with php71 or higher?
AFAICR we had to downgrade to 7.0 when installing it.


#3

#4

Yes we have, we are running weathermap plugin with PHP version 7.2.11. No issues so far.


#5

Good news! is it a version from GitHub?


#6

Ubuntu 16.04 (Xenial) still has 2 years of life left, yet it is stuck at PHP 7.0. It would be a shame to drop it given it was the distro recommended by the LibreNMS docs only 4 months ago.


#7

Redhat / CentOS 7.6 (last official version), with all the latest updates, still using PHP 7.0.33… :frowning:


#8

RHEL / CentOS ship with PHP 5.4… You are using a repository for your PHP and most repositories have the latest versions of PHP. Just google how to switch to PHP 7.2 for the repository you are using.


#9

You can use a PPA to upgrade PHP if you want to continue to use 16.04 or you could upgrade to 18.04, which has PHP 7.2.


#10

Pretty crazy that 7.1 will stop receiving security updates and bugfixes before the end of 2019 already. I kinda wish PHP would release another LTS version.


#11

We run Ubuntu 16.04 and have been running PHP 7.3 with LibreNMS and Weathermaps for a few weeks now, without any issues. Upgrading using a PPA was fairly straightforward. If you use Apache, just make sure you tell Apache to use 7.3 instead of the default 7.0.